Unable to connect to custom server


#1

heloo,
I’m create my server , when i’m connect to my client the log of android studio show this message:
using server prime.kontalk.net|172.16.30.148:5222
05-15 12:41:26.181 5181-5825/org.kontalk.debug E/MessageCenterService: connection error


#2

Hello and welcome.
I’ll need the full stacktrace of the error to determine what’s wrong.

I’m assuming you used the Docker environment. If you’re trying to connect to your own instance, there is probably something wrong with it. I’ve closed your other two topics so we can focus on this one. So let’s check the full Android error and the server logs too. You can paste them here or use a pastebin service (e.g. pastebin.com).


#4

Hello and Thank you for the advice,
I’m used Docker environment. and I’m doing all step (Setting up environment, Requirements) in https://github.com/kontalk/xmppserver-docker

this is android studio logs:
https://pastebin.com/tFE4QtGA

this is local.properties:
https://pastebin.com/CwBX3tgi

this the server logs:
https://pastebin.com/fQin5Quk

finally, please make video tutorial in youtube of install Kontalk server for Docker and connect to the android client in emulator to make work easy. And I’m speak Arabic fluency i will translate the video to be contributed.


#5

The problem seems to be on the client:

05-29 03:26:07.923 1168-6895/org.kontalk.debug D/MessageCenterService: using server prime.kontalk.net|192.168.230.129:5222
05-29 03:26:07.971 1168-6895/org.kontalk.debug E/MessageCenterService: connection error
                                                                       org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: '192.168.230.129:5222' failed because: de.measite.minidns.hla.ResolutionUnsuccessfulException: Asking for 192.168.230.129.    IN  A yielded an error response NX_DOMAIN, '192.168.230.129:5222' failed because: de.measite.minidns.hla.ResolutionUnsuccessfulException: Asking for 192.168.230
.129.   IN  AAAA yielded an error response NX_DOMAIN

What did you insert in the “manual server address” preference in the app?
What version of the app from git are you using?


#6

Hi,
In the setting>network>manual address I’m insert “prime.kontalk.net|172.16.30.148”.
The version of the source code (app) 4.1.0-preview(242).
and still don’t connect.


#7

Ok first of all update the version of the app (4.1.6 as of today), because there were fixes in the meantime concerning usage of a manual server address.