Delay in receiving messages (f-droid version)


#1

Hola.
Quiero agradecer a todo el equipo desarrolladores por el trabajo realizado con esta aplicación de mensajería instantanea en software libre, este año hemos promovido a kontalk y estamos muy contentos de la nueva utilidad de los grupos, esperamos que esto nos ayude a tener más gente en nuestra red.
Tengo una pregunta: ¿qué puede pasar que los mensajes de kontalk se demoran en llegar a mi teléfono? llegan un poco después del tiempo en que me lo envían… ¿será que debo configurar algo más en el kontalk? yo utilizo Fdroid y no tengo googleplay.

Agradeciendo y FELICIDADES al equipo de desarrolladores en este nuevo año.


[ES] Issues upgrading to beta5
Looking back to 2016. Leaping forward into 2017
#2

Hi @JorgeA,
HAPPY NEW YEAR!

Would you mind to try to write in english? I’m not a native english speaker. My english is really bad. But in spanish I only can read with googe translater. And I’m sure you know, that’s a really bad solution :wink:

About your problem as far I understand. F-Droid version don’t support push messages?!
So you can set the connection interval in ‘networksettings’. The shortest interval is 5 minutes.

I use the Google Play version. And so I’m not absolutely sure. Maybe someone can confirm or correct my statement.

I hope I could help


#3

Actually, in F-Droid, “Disconnect when idle” should be set to “Never”, which should be the default.


#4

Hello @JorgeA and welcome to the Kontalk forum! I kindly ask if you could write in English since it’s the default language here.

As I used Google translators too I can understand your problem could be with missing push notification, as @webratte said. It should be default on the F-Droid version, but your “Disconnect when idle” preference (In Kontalk settings > “network settings”) should be set to “Never”.


#5

@webratte, @SylvieLorxu you’re becoming even faster than me :stuck_out_tongue:


#6

Hola Daniele y todos los amigos de Kontalk.

En la actualidad he sumado mucha gente cercana a la red de kontalk, a pesar de que ellos prefieren whatsap… Ellos me dicen que con Kontalk los mensajes les llegan mucho tiempo después de que lo envían o lo reciben retrasado…

A mi me pasa que cuando tengo red de internet, debo entrar a la aplicación de Kontalk para que me lleguen los mensajes de kontalk, algunas veces NO me avisa de los mensajes que me han enviado mis amigos por kontalk, Sino que debo entrar a kontalk.

Yo organice en la opción de configuración de red que dice desconectar estando inactivo, la opción de Nunca. En la opción volver a conectar con el servidor coloque 3 horas.

¿Esto lo puedo mejorar, para que los mensajes que envío o me envían me lleguen rápido? Yo estoy con una verisión 4.00 bajada por F-droid.
Agradezco si me pueden ayudar con este tema

Agradciendo,
Jorge A.

Hello Daniele and all Kontalk friends.
Currently I have added many friends to the kontalk network, even though they prefer whatsap … They tell me that in Kontalk messages arrive long after they send or they receive it delayed …

It happens to me that when I have an internet network, I have to go to the Kontalk application to get the messages from kontalk, sometimes it does not notify me of the messages sent to me by my friends by kontalk, But I have to go to kontalk .
I organized in the network configuration option that says disconnect being inactive, and I chose the option Never. In the option reconnect with the server, enter 3 hours.

Can I improve this so that the messages I send or send me arrive fast? I am with a 4.00 verision down by F-droid.
I appreciate if you can help me with this topic

Thanking,


#7

Hi @JorgeA

I’m not sure. And I don’t know the exactly technical background.

But I think this is a Android thing.

If a background service is for longer time not used (no message for Kontalk). Android say it have to sleep and will waked up only every 10 minutes or so to look for new Push messages to save battery.

If you or your friends not receive many messages it takes a few minutes to wake up the Kontalk background service.

I belive your friends with WhatsApp have many other WhatsApp users and receive many messages in shorter time then Kontalk messages.

So WhatsApp background service is longer awake then asleep.

Maybe I’m wrong. But that is what I read some where in the Internet.

Hopfully more tech users will answere too your post.


#8

Hello @JorgeA,
I also believe this is an Android issue and its maniacal attention to energy saving. What Android version are you running and on what device model? Starting Android version 6 some heavy stuff like Doze mode can currently kill the Kontalk service at random times. I’m afraid I’ll need to implement foreground service notification sooner or later…


#9

Hola Daniele.
Lo más importante de Kontalk es que es software libre. Pero cada vez que utilizamos más el kontalk, estamos requeriendo que el kontalk nos avise de los mensajes cuando tenemos internet wifi.
Ahí lo que pasa es que cuando estamos conectados las respuestas nos llegan tarde. No nos avisa sino cuando activamos el kontalk.
El Android que yo tengo es 7,1 y mis amigos tienen diferentes versiones, desde la versión 6… Algunos instalamos el Kontalk desde f-droid, y otros pocos desde Playstore. Los de Playstore les avisan algunos mensajes, además ellos tienen notificaciones Push, creo que eso ayuda.
Estamos seguros que esto va a mejorar, pero eso es lo que nos pasa.


Hi, Daniele.
The most important thing about Kontalk is that it is free software. But every time we use the kontalk more, we are requiring that the kontalk warn us of the messages that respond or send us, we require that you have immediate notifications.
What happens is that when we are connected the answers are late. It does not notify us until we activate the kontalk.
The Android that I have is 7.1 and my friends have different versions, since version 6 … Some install Kontalk from f-droid, and a few others from Playstore. Those who installed from Playstore, the kontalk warn they you of some messages, in addition they have Push notifications, I think that helps.
We are sure that this will improve, but that is what happens to us.


#10

@JorgeA,
please ensure that your Kontalk network settings are set like this:

  • Disconnect when idle: never
  • Reconnect to server: 5 minutes

If that still doesn’t fix your problem, please check any energy saving component that might kill Kontalk in the background. Several phone manufacturers put their own version of automatic task killer which doesn’t really help in most cases, it just causes issues like this you’re having.


#11

Hola Daniele.
Estoy corrigiendo lo de Reconcectar el servidor (volver a conectar al servidor), lo tenía en 3 horas y lo cambie como usted me dice.

Yo tengo un moto - g primera generación y otros tienen un samsung j-5.
Miré en la configuración del celular, por notificaciones y mostraba que para Kontalk “Allow sounds or vibration no more than once every 30 minutes” esta opción la cambié a “NO restriction”.
En la configuración del ahorro de la bateria esta desativado “Extreme power saver” y el automatic optimization.
Yo les voy contando cómo me va con estas sugerencias que usted me hace.
Muchas gracias :relaxed:
Disculpa la traducción…


Hi, Daniele.
I am correcting Reconnecting the server (reconnecting to the server), I had it in 3 hours and change it as you tell me.

I have a first generation moto - g and others have a samsung j - 5.
I looked at the configuration of the phone, by notifications and showed that for Kontalk “Allow sounds or vibration no more than eleven every 30 minutes” this option changed it to “NO restriction”.
In the configuration of the battery saving is disabled “Extreme power saver” and automatic optimization, never.
I am telling you how it goes with these suggestions that you make me.
Thank you very much: relaxed:
Sorry for the translation :smirk: