how can I configure the server on AWS?

Good morning,
I would like to test the server on an AWS machine, can you advise me how to configure it?

I need it to test the server and distribute it to 10 people under test

Hello and welcome,
I’ve never used AWS, but as long as you have a Linux distro and Docker, our Docker setup should work fine.

Thanks for the reply, how can I tell if the server has started? I tried to configure it and start it, I connected with the public IP and nothing, with the public dns that from AWS and nothing, I can’t understand if I have to do something more or if it hasn’t started.

however, I used the guide on github

Well the host should reply to TCP connections at least on port 5222. If it doesn’t, you should check the server logs, it should state that it started listening on that port. If it doesn’t, check that you don’t have any exceptions or errors (Tigase sometimes just goes on booting even if some errors are critical).
If the logs are unclear, use a pastebin and share the link here, I’ll help you if I can.

What guide? The README here is what you should follow.

yes, this is the guide I followed

I tried this one “./launcher logs” , but it doesn’t show the log
Are the files for ssl certificates necessary?

Please provide more information about what you’re doing and what you’re seeing. It’s really hard to help you otherwise. What do you mean it doesn’t show the log? Does it output some other error? Or is it just blank screen? What about the “./launcher bootstrap” command?

All the commands for “./launcher” that I run do not output, only this “./kontalk-setup” command allows me to configure the server

That’s weird… what if you run ./launcher without arguments? Do you get the help screen?

By the way what OS is your AWS machine running?

Yes, if I send the command “./launcher” the help info will exit.
I created an Ubuntu machine

How about (while standing in the repo folder):

IMAGE_VERSION=$(cat .version) docker-compose -p ${INSTANCE_NAME} up

Replace ${INSTANCE_NAME} with the value you set in

nothing does not work, I give up so much if it did not work by today they told me that they would not take it into consideration (they asked me to do research is not something that serves me personally)

I see. I’m sorry to hear that. It’s hard to debug those kind of issues remotely. I can’t think of a reason why docker-compose should not output something, it’s not even our launcher script itself. You could try using docker-compose in any other way to see if the whole thing is working (Docker + docker-compose).